How To Connect OnPremise NAV to PowerApps/PowerBI Content Packs

Having problems creating a connection to NAV on-premise in PowerApps and connecting to any of the NAV PowerBI content packs. Am getting authorization errors.

Does anyone know if the NAV instance/service have to be configured with the NavUserPassword authentication in order for this to work? Does the data gateway have to be installed (it is not but SSL is all set up, I think correctly). I have been trying this for days and ours is set to WIndows authentication. Outside the firewall, I can use the Get Data command to connect PowerBI to the NAV data, can also use the NAV Webclient and the Windows 10 client app and successfully connect to NAV data. However, if I try to create a Connection in PowerApps or use 1 of the NAV content packs in PowerBI, I get authentication issues.

Just read the post: https://dynamicsuser.net/nav/b/peik/posts/setting-up-powerbi-online-with-dynamics-nav-docx?tempkey=9b8c06ed-9be3-4716-8528-ff1ab28181be#

In it the author mentions that "The DynamicsNAV90_NUP service has been configured with the NavUserPassword authentication."

Could that be due to the NavUserPassword vs Windows authentication?

  • I should mention that we are using NAV 2016 on-premise (hosted) and appropriate OData and SOAP ports have been opened
  • In reply to DB:

    So you're able to make a functional to your NAV installation using for example your smartphone?

    Maybe knows the answer?

  • In reply to Erik P. Ernst:

    Sorry, make a functional ? what? I can open a browser on my PC and connect using the web app client. I can also open the windows 10 Dynamics NAV app and connect. Don't know about from phone. No app for mine. I can also open PowerBI and use the connect to data menu item and connect to the NAV OData connection. What doesn't work is trying to create a connection to NAV through PowerApps nor does trying to create a connection to one of the NAV "content packs" in PowerBI.
Related