Navision 3.51A DOS with Virtual PC

Hi I have an customer that runs 3.51A on a NT 4.0 Server
and the clients on Win95/98.


Two PC needed to be replaced with two new Windows XP machines.

I installed Virtual PC on the Win XP PC

Virutal PC runs Win98
and configured

with
TCP/IP
netbuie
hosts fil = naviserv1

I try to start Navistar.bat

I have any mapped K:/navision
Where the database are

I start navistar.bat from the client installtion and in starts upp Navision Dos window, but after 10 sec its disconnect and say cant found the correct host, check the hosts fil.

But I have copied the fil from an working Navision client installtion.

Need help,

Best Regards

Andreas Fransson
  • Can't you run navi2 in OS/2 emulation mode, or does that not work on XP?
  • quote:
    Can't you run navi2 in OS/2 emulation mode, or does that not work on XP?
    Originally posted by David Singleton - 2005 Dec 14 : 18:11:18


    navi2 is definately working under XP (with a local database and a warning message that the application would like to have a direct disk access (16-bit mode)). However, I guess the problem is netbui. Try to remove the netbui protocol and start Navision by using navi2 nettype=tcpf (you have to start the server accordingly)
  • navi2.exe : programlicens for NAVISION cant use this OS.
    What do I need to do to make it work.

    Is it ok to upgrade them to 3.56A do this solve the problem.
    Or can we solve it with Virtual PC and still working with 3.51A

    OS/2 emaulation??

    I can make it work with 3.56A with a mapped database from the server.

    But I want to have TCP/IP working.

    Thanks

    Andreas
  • You need to use navin.exe to use tcp (pay attention to the n in navin) but then you need the win32 execution granule on your license.

    As i recall navin.exe was available from version 3.56.

    If you want to use tcp with navi.exe you would need a dos tcp-stack.

    This has been done but is difficult.

Related