NAV 2013 R2 PDF report Issue

Ever have an issue with a nav 2013 r2 report where a certain text box would get excluded from the PDF output file (save as pdf on request page)?

 

This seems to works when you save as word and also the text box shows up on previews, even shows in the PDF file when you save as pdf from the preview screen?

 

I'm stuck. any help advice appreciated.

 

There is no overlapping of other text boxes either.. Works one way, does'nt work the other

  • Is this text box from the request option or a field from a table?
  • So when you print it it works, but when you save it to PDF, then it doesn't work? How does it work in preview?
  • In reply to sbhatbng:

    This is a text variable which i'm passing from the dataset.

    Print Preview from request page = works, shows the text

    Save as DOC from request page = works, the doc file contains the text box with my text box in it.

    Send to printer from request page = works, shows the text

    Save as PDF from the print preview window (NAV report viewer) = works, the pdf contains the text box with my text box in it.

    Save As PDF from the request page = does not work, that text box is missing

    can't be overlap or another box being set to 'cangrow'?. otherwise it wouldnt have worked in the other instances
  • In reply to Erik P. Ernst:

    hi Erik, see my answer to sbhatbng, thanks.
  • As this was part of terms and conditions i moved the text box from the main body of the layout and created a footer section and inserted it there. It seems to work this way consistently whichever way I output, however it would be interesting to know what might affect the PDF rendering for this text box when saving as PDF one way as opposed to the other way.

Related