Quick Tip: How to fix the Business Central on Premises 2020 Wave 1 Installation Error?

Microsoft released Dynamics Business Central on Premises 2020 Wave 1 and you can download the On Prem installation DVD here:

But when you do an installation, you might get the following error:

This happens if you don’t meet the system requirements:

To confirm, you don’t need the SQL enterprise edition, SQL Express is also supported. To be more specific, this error is because I was not using the correct SQL Server Express edition. I was using version 2016, and you need at least:

  • Microsoft SQL Server 2019 Express, Standard, or Enterprise.
  • Microsoft SQL Server 2017 Express, Standard, or Enterprise.
  • Microsoft SQL Server 2016 Express, Standard, or Enterprise (Service Pack 1 or later).
  • Azure SQL Database Managed Instance, Elastic Pool, or Single Database.

So I downloaded and installed Microsoft SQL Server 2016 Service Pack 2 (SP2):

Then I repaired Business Central on Premises 2020 Wave 1 and the problem was fixed:

Comment List
Related
Recommended