How Do I: Set the runtime version of the extension package?

Recently, on some of my ‘machines’ I get the following errors, when trying to publish an extension (F5):

The runtime version of the extension package is currently set to '2.0'. 
The runtime version must be set to '1.0' or earlier in the app.json file 
in order to install the extension package on this platform.

Apparently, this is a new feature because the AL language extension is compatible with multiple platform versions. You can install the AL Language extension from the Visual Studio Code marketplace and use it to develop solutions for Dynamics 365 Business Central.

To set the platform version, add the runtime property in the app.json file. This attribute defines the platform version that the extension is targeting. Depending on the platform version, some features become available, while some features are not supported.

The following two elements are compared when you publish an extension.

  • The runtime version of the extension defined in the app.json file.
  • The runtime version of the platform that the extension is targeting.

In the app.json file, set the extension runtime version lower than the platform version. When you set the extension to a higher runtime version, the extension package may contain certain features that the platform may not support which would result in an error. Therefore, you must lower the extension runtime version than the one that platform supports in order to publish your extension.

More information available here:

https://docs.microsoft.com/en-us/dynamics365/business-central/dev-itpro/developer/devenv-developing-for-multiple-platform-versions

 

Comment List
Related
Recommended