Permission issue with deployment administrator account

Former Member

Hi there,

I have issue with permission when I want to manage user roles in CRM 2016 (on premise).

I got "Insufficient permissions.

You do not have the required permissions to access these records. Contact the Microsoft Dynamics 365 administrator. When contacting Support, provide the technical details."

I'm using deployment admin account for this.[

And this is not only issue I have with permissions, this usually happens a lot. 

In event viewer I get issues Event 18949 MSCRMKeyGenerator - expired ( for that I restarted Async service and tried with Microsoft.Crm.Tools.WRPCKeyRenewal.exe /R command, but no help ), and also

I have MSCRMMonitoringTest - failed, with different variety of Event ID.

But those errors I usually have, there is not a single issued error when I try to manage user permission.

That user is global (domain) Administrator account. Not possible even with that one. 

That account has even less possibilities, less info shown in CRM. 

Also, I have added deployment admin rights to organisation owner, and also domain rights like user which was created for CRM installation, so now owner is able to change user licences but still not able to manage user roles in his own organisation.

Can I get guidance how should I proceed with troubleshooting, since I'm not familiar with this Microsoft product.

Thanks

Parents
No Data
Reply Children
No Data
Related
Recommended