This discussion has been locked.
You can no longer post new replies to this discussion. Posts are automatically locked, when no new replies have been made for a long time. If you have a question you can start a new discussion.

Authentication Error

I am in a bit of pickle. In fact, that's an understatement, I am in a whole world of trouble if I can't get this resolved...

We run MSCRM 3.0 on a SQL Server 2005 database.

Several months ago we had a power surge that blew one of the disks on the server. Ever since then, we haven't been able to take a backup of the database, which often goes into Emergency Mode. A DBCC check and repair did nothing.

Anyway, over this weekend I ran the Stellar Pheonix recovery software, which apparently repaired the database. I was pleased to see that I could take a backup of the newly created recovered database and thought my worries were coming to an end. However, when I tried to restore this backup to the live database, it got stuck in Restore mode. To cut a long story short, I ended up deleting the original database, thinking I could just rename the recovered version, and CRM would run again. However, now I have done this, I get an error when trying to run CRM over a web browser -

AUTHENTICATION ERROR - Microsoft CRM could not log you onto the system. Make sure your user record is enabled and you have been assigned at least one security role. For more information, contact your system administrator.

I'm guessing it's a User / Security Role issue, but I can't seem to figure it out. My user account has the required role....I think.

Does it matter that my "new" database is using differently named .mdf and .ldf files than the original?

One other thing, when I run the Deployment Manager, and try and Configure SQL Server, it tells me no CRM Databases are found on the server.

Please, please, please help.