Dynamics User Group - Archived Forums

The forums in this section of DUG are no longer accepting new post, but you can still get lots of value from the old posts here.
Please visit the active forums to comment/post new questions (choose which product you are interested in):


On Sales order, Unit cost not updated

Hi All,

I have come across a bug on the sales order, when you enter a sales order for an item which was newly created, qty = 0 and unit cost = 0.

You enter the sales order for this item. The system default the unit cost as zero on the sales order line.

now you raised a PO and then receive the item in stock with the right cost. on the item card the cost and qty is updated.

If you go back to the sales order, and ship the stock, the unit cost remain zero. The effect is that you have a wrong profit calculation and all the reports that use the sales and cost calculation is wrong.

when I verify on the posted sales invoice, I can see that the unit cost is zero. However, the gl and inventory is being updated with the right cost.

have anyone come across this bug?

thanking you in advance
  • Hi

    Run the Adjust Cost Item Entries batch job. You should be running this in tandem with the Post Inventory to GL batch job. Please look at these and the impact of them in detail. When you run the first on you'll see the cost of the associated sale get updated.
  • Running the Adjust Cost Item Entries will only adjust values in the Value Entry Table and will not update the actual posted document. Or any other documents for that matter.

    Loads of people have complained about this but as of yet I am not aware of any official fix.
  • Hi

    In some areas and some reports, this is not updated, however the transaction detail (Item ledger Entry) and GL will see the costs. This area is inconsistent in its views and data, but this is because they bring the information from different areas of the system. Maybe one day it will be perfect Wink
  • In fact this is a known issue that cost information won't get updated in sales. If you have standard costing it is not really an issue, though very annoying if you have average costing http://www.mbsonline.org/forum/topic.asp?TOPIC_ID=11827)

    What you might consider is to inlcude a sales line update (table 37) once you are running the Adjust Cost Item Entries process to make sure that the items to sell reflect the latest unit cost.

    Saludos
    Nils
  • Annoying, ongoing and not likely to be resolved anytime soon by MBS was the conclusion we arrived at in the other thread. It has been wrong since Navision was invented and without major re-writes you are best to go off your GL figures if you care for accuracy.

    Meint
  • It's probably the easiest just to use sales reports that are coming from either the value entry table or the item ledger entry table, i.e. Customer/Item Statistics. Sad
  • If I understand the problem correctly we solved this by revalidating the item line on the sales order for that new item.
  • quote:
    If I understand the problem correctly we solved this by revalidating the item line on the sales order for that new item.

    Originally posted by JackY - 2004 Oct 06 :  22:05:40



    This will work, but only in some cases, i.e. once the line has shipped you can no longer do this. Also, it re-validates the selling prices so you now have to check those if you have amended them. Another solution is to write a bit of code that updates the unit cost to the latest average just before posting the line, but this again not without its flaws. We had weeks of fun looking at this issue as it was a major show stopper and it really needs MBS to have a good look at this issue. Yet another problem is that in 3.70 the unit cost on the item card will not be updated to the latest average cost until you run the adjust cost item entries routine (another thread on this somewhere), so even re-validating the line does not always give you the latest average cost :(
  • Thanks guys,
    I see this is a known issue where we don't really have a solution.

    I will go with the solution of updating or refreshing the unit cost upon posting. As this comes closer to the solution.

    Thanks
  • A related issue is that I don't believe that the General Business and General Product Posting groups get updated. Whilst there is generally a low rate of change amongst such things, you could end up with incorrect GL posting accounts if the groups were changed between capture and posting dates. Incidentally, it also makes a mockery of the profit calculation when you use the F9 function.
Related