Report as finished error - quantity cannot be picked as 0 is available

Latest Axapta / Dynamics AX FAQ Pages

Get our Free Newletter

Don't you have the time to be online here at DUG every day? So how do you follow what is going on in the Dynamics industry and community?
If you subscribe to the DUG Newsletter then you can relax! We will make sure that you don't miss the big news!

Check out our
Newsletter Subscription Center
page a complete list of our different newsletters.

Solution (Verified) This post has 2 verified solutions | 24 Replies | 1 Follower

480 Posts
4,827 Points
Joined: 2012-11-4
Last Online:
2013-7-29 23:26
Location: Hoboken New Jersey
Patrick Am posted on 2013-1-9 2:50

Hi, I am running AX 2012 FP where my inventory model is FIFO with no negative inventory physical 

I receive the raw item in inventory warehouse location (10) and on-hand shows that it is sitting in the correct location 

that's the only part on a BoM, the production will place the finished good at location 30 

automatic BoM and route consumption When I post the picklist it is correctly showing the amount in WIP. 

after posting the pick-list, when I report as finished I am getting the following error. 

Have anyone come across this scenario (when I allow pick negative from Inv model it is working fine). 

The quantity cannot be reduced. The number of inventory transactions on order is too low because the quantity or part of it is referenced by an output order or a production order or is marked against other transactions.

Solution (Verified) Verified Solution

Male
10,914 Posts
174,833 Points
Joined: 2000-11-3
Last Online:
2014-7-29 16:56
Location: UK
DynamicsNAVMVP
Moderator
Solution (Verified) AdamRoue replied on 2013-1-9 21:07
Verified by Patrick Am

You were at the wrong parameter Big Smile

Journals tab and Route card/Job Card Journal "Automatic BOM Consumption" I presume this is ticked? Un tick it. This will impact on the route card journal as it will not tick BOM consumption on creation.

Also remove the operation from the BOM line in a test.

“Any fool can know. The point is to understand.”
Albert Einstein

Male
10,914 Posts
174,833 Points
Joined: 2000-11-3
Last Online:
2014-7-29 16:56
Location: UK
DynamicsNAVMVP
Moderator
Solution (Verified) AdamRoue replied on 2013-2-8 22:12
Verified by Patrick Am

I would go for option 2. and I would ensure that in the future there is a process to move stock into the production area where it is being made (location) to ensure the stock is consumed from the correct location.

“Any fool can know. The point is to understand.”
Albert Einstein

All Replies

Male
10,914 Posts
174,833 Points
Joined: 2000-11-3
Last Online:
2014-7-29 16:56
Location: UK
DynamicsNAVMVP
Moderator
AdamRoue replied on 2013-1-9 8:30

Your BOM Consumption on the RAF parameters is set to "Always" or "flushing method" and there is no stock, it is trying to double consume as you are telling it to do this.

“Any fool can know. The point is to understand.”
Albert Einstein

480 Posts
4,827 Points
Joined: 2012-11-4
Last Online:
2013-7-29 23:26
Location: Hoboken New Jersey
Patrick Am replied on 2013-1-9 8:48

On the start stage (of production parameters for MES), i set auto-consumption to always for both pick and route 

on operation and RAF stage, i set the auto-consumption for both Pick and route to never.  With these settings, I am able to post both pick and RAF journals. However, when I post the route card, I am getting a warning message as below. Is there a reason why? 

Posting Route card Journal 

Journal has been posted. 

Posting picklist journal 

item number xxxx 

physical on-hand 

site '10' warehouse 'abc' location '1'

1 quantity cannot be picked because '0' quantity available 

***  Looks like it tries to post the

pick-list journal again (while posting RAF). why?  I posted the pick-list at the start of the production operation. After that, I report as finished and then am trying to post the route card with actual hours (operational scheduling). 

Is there anything that need to consider to disable 'pick-list journal' from being posted again during the RAF stage. 

many thanks for your help. 

480 Posts
4,827 Points
Joined: 2012-11-4
Last Online:
2013-7-29 23:26
Location: Hoboken New Jersey
Patrick Am replied on 2013-1-9 8:50

Hi Adam, thank you for clarifying it. You are absolutely correct. I set the 'auto consumption' to never for RAF and it worked fine. However, while posting the route card journal, it gives me a warning - I think I am double posting the pick-list during the RAF stage. please let me know where I am going wrong. thank you 

Male
10,914 Posts
174,833 Points
Joined: 2000-11-3
Last Online:
2014-7-29 16:56
Location: UK
DynamicsNAVMVP
Moderator
AdamRoue replied on 2013-1-9 8:55

When are you posting the route journal - there is a posting for this on RAF and Start as well. In addition you can link BOM lines to routing operations, check your routing and BOM links as well.

“Any fool can know. The point is to understand.”
Albert Einstein

480 Posts
4,827 Points
Joined: 2012-11-4
Last Online:
2013-7-29 23:26
Location: Hoboken New Jersey
Patrick Am replied on 2013-1-9 9:02

Hi Adam, I am posting route card after RAF. I set the route 'auto-consumption' to always at the Start and in the RAF, i set the auto-consumption for Route card journal to 'never'. 

480 Posts
4,827 Points
Joined: 2012-11-4
Last Online:
2013-7-29 23:26
Location: Hoboken New Jersey
Patrick Am replied on 2013-1-9 9:20

Hi Adam, I have a very simple routing with 1 route for the Parent BoM and 1 for the sub-BoM.  In fact, In this example, I have one item associated to the BoM that has 1 route operation. 

While Posting picklist, i noticed that  auto-consumption is selected for the route card/journal section of the set up tab (of the picklist journal). I unchecked, but it still is giving me the error? 

Male
10,914 Posts
174,833 Points
Joined: 2000-11-3
Last Online:
2014-7-29 16:56
Location: UK
DynamicsNAVMVP
Moderator
AdamRoue replied on 2013-1-9 10:19

You will need to step through this but by bit

Post route at start as ALWAYS, ensure post route card is checked. Post Pick at start. The remaining status of teh order should then be RAF. Post pick journal.

Then ensure on RAF Route and Pick are NEVER

Is your Sub-BOM an item or is it a referenced production order? If referenced ensure this is all closed off before processing the parent.

“Any fool can know. The point is to understand.”
Albert Einstein

480 Posts
4,827 Points
Joined: 2012-11-4
Last Online:
2013-7-29 23:26
Location: Hoboken New Jersey
Patrick Am replied on 2013-1-9 17:21

Hi Adam, thank you. I step through this as you from start to RAF. Everything works fine. But when I post the route, it is throwing a warning - as it tries to post the pick list again and it couldn't find quantity

At start, I have both Pick and Route consumption as "Always" 

Then I post the Pick-list.

Post the RAF - I set both Pick and Route consumption is "Never". 

Finally I post the Route - The route card journal is posted. However, the info log shows me that Pick-list journal couldn't be posted as there is 0 quantity.  I am not sure why AX giving me this warning. 

 

 

Male
10,914 Posts
174,833 Points
Joined: 2000-11-3
Last Online:
2014-7-29 16:56
Location: UK
DynamicsNAVMVP
Moderator
AdamRoue replied on 2013-1-9 18:06

In the Production Control Parameters on teh Journals tab and Route card/Job Card Journal do you have "Automatic BOM Consumption" ticked?

In the BOM on the general tab is the operation number populated?

Is your picking end marked?

“Any fool can know. The point is to understand.”
Albert Einstein

480 Posts
4,827 Points
Joined: 2012-11-4
Last Online:
2013-7-29 23:26
Location: Hoboken New Jersey
Patrick Am replied on 2013-1-9 19:14

Hi Adam, I checked the production control parameters and yes I have selected 'Automatic boM consumption' as "always" for the route card/pick journal. However, I didn't select the "Automatic BoM consumption for route card journal" 

Automatic update section, I have auto bom consumption 'always' and route consumption never for the Automatic execution; For auto-report as finished, I have auto bom consumption as 'Never' and route consumption 'Always' 

I ensured that the operation number is populated on the BoM line. 

Also I selected 'End mark' for picklist at the Start and RAF stage.  

I noticed that when I select 'end mark' for route card at the RAF stage, it posts the route card. When I don't end-mark the route, during RAF stage, the route card journal is posted.

after that, when I try to post the route card, the route card journal is posted However, it also posts the picklist (that double my material consumption.  

Any idea if I am missing anything. 

 

480 Posts
4,827 Points
Joined: 2012-11-4
Last Online:
2013-7-29 23:26
Location: Hoboken New Jersey
Patrick Am replied on 2013-1-9 20:20

Hi Adam. I found one thing that's quite interesting. probably I may need to do this.

While posting the route card (after RAF), i notice in the journal line the BOM consumption is checked.  When I unchecked that, it route card journal posted without any hitch. (and it didn't post the pick-list journal again this time).   Does it mean that, i need to uncheck this option every time I post the route card journal?  

also when is the best time to post the route card. Is it after RAF or prior in general? 

many thanks  

 

Male
10,914 Posts
174,833 Points
Joined: 2000-11-3
Last Online:
2014-7-29 16:56
Location: UK
DynamicsNAVMVP
Moderator
Solution (Verified) AdamRoue replied on 2013-1-9 21:07
Verified by Patrick Am

You were at the wrong parameter Big Smile

Journals tab and Route card/Job Card Journal "Automatic BOM Consumption" I presume this is ticked? Un tick it. This will impact on the route card journal as it will not tick BOM consumption on creation.

Also remove the operation from the BOM line in a test.

“Any fool can know. The point is to understand.”
Albert Einstein

480 Posts
4,827 Points
Joined: 2012-11-4
Last Online:
2013-7-29 23:26
Location: Hoboken New Jersey
Patrick Am replied on 2013-1-9 21:48

Hi Adam, yes. that did the trick. Thanks again for the great help. 

Male
10,914 Posts
174,833 Points
Joined: 2000-11-3
Last Online:
2014-7-29 16:56
Location: UK
DynamicsNAVMVP
Moderator
AdamRoue replied on 2013-1-9 21:50

No problem, glad you are having fun Big Smile

“Any fool can know. The point is to understand.”
Albert Einstein

Page 1 of 2 (25 items) 1 2 Next > | Get this RSS feed | Bookmark and Share