Get our Free Newletter

Don't you have the time to be online here at DUG every day? So how do you follow what is going on in the Dynamics industry and community?
If you subscribe to the DUG Newsletter then you can relax! We will make sure that you don't miss the big news!

Check out our
Newsletter Subscription Center
page a complete list of our different newsletters.

This post has

Male
7,691 Posts
436,003 Points
Joined: 1995-10-1
Last Online:
2014-10-31 23:58
Location: Middelfart, Denmark
DynamicsNAVMVP
SystemAdministrator
Erik P. Ernst Posted: 2008-12-17 9:28 | Locked

In my Microsoft Dynamics NAV 5.0 SP1 we have two languages installed. English and Danish. We run it under Citrix.

Whenever a new user who previously never have used our Navision logs into the system, then the language is always set to Danish. That's fine for the Danish users, but not so fine for the users from the other countries.

Do you know how I can change the Default Language upon startup?

 

Best regards,
Erik P. Ernst
Webmaster 

DUG’s Admin's Blog

Don't forget to "Verify Solution" the post(s) that solved your problem. This credits the experts who helped, earns you points and marks your thread as Resolved so we all know you have been helped.

Male
1,294 Posts
28,076 Points
Joined: 2006-9-21
Last Online:
2014-8-26 16:49
Location: Delhi-India
Moderator
Dhan Raj Bansal replied on 2008-12-17 9:38 | Locked

Try following:

In CodeUnit 1 (Application Management), ApplicationLanguage Function change the value to your language code.

EXIT(YourLanguageCode);

-Dhan Raj Bansal

Linkedin Profile: http://in.linkedin.com/in/dhanrajbansal

Male
7,691 Posts
436,003 Points
Joined: 1995-10-1
Last Online:
2014-10-31 23:58
Location: Middelfart, Denmark
DynamicsNAVMVP
SystemAdministrator
Erik P. Ernst replied on 2008-12-17 10:54 | Locked

Doesn't work.

The Danish language is on the client, even before you get to choose the database.

Are there any of the files in the client library specifying which language folder to start in?

Best regards,
Erik P. Ernst
Webmaster 

DUG’s Admin's Blog

Don't forget to "Verify Solution" the post(s) that solved your problem. This credits the experts who helped, earns you points and marks your thread as Resolved so we all know you have been helped.

Male
2,117 Posts
45,466 Points
Joined: 2005-12-6
Last Online:
2014-10-31 22:37
Location: Rælingen (Akershus), Norway
Moderator
Modris Ivans replied on 2008-12-17 15:28 | Locked

Language setting is saved in ZUP - you can copy a zup file with this setting (language) saved to each user...

Modris Ivans
MCP-Dynamics NAV Application

Please specify in your posts
1.product and DB version;
2.locale, or use International Forums

"Verify Solution" that helped you solve your problem

Male
7,691 Posts
436,003 Points
Joined: 1995-10-1
Last Online:
2014-10-31 23:58
Location: Middelfart, Denmark
DynamicsNAVMVP
SystemAdministrator
Erik P. Ernst replied on 2008-12-17 18:08 | Locked

Good point about the ZUP file, and if there really isn't any other way, then it could be used.

But I have a hard time believing that there isn't there any other way to set this, without having to copy a default ZUP file to all users?

Best regards,
Erik P. Ernst
Webmaster 

DUG’s Admin's Blog

Don't forget to "Verify Solution" the post(s) that solved your problem. This credits the experts who helped, earns you points and marks your thread as Resolved so we all know you have been helped.

Male
2,117 Posts
45,466 Points
Joined: 2005-12-6
Last Online:
2014-10-31 22:37
Location: Rælingen (Akershus), Norway
Moderator
Modris Ivans replied on 2008-12-17 19:09 | Locked

There is not a command line parameter for this purpose... I found 12 possible parameters (ver 5), but Language is not there Sad

 

 

 

 

 

 

 

 

 

 

as command line parameter:

• ID - Saving the User Setup

• Server Name - Choosing the Server

• Database - Selecting a Database

• Company - Selecting a Company

• Windows Authetication - Selecting the Authentication Mode

• Commit Cache - Writing the Cache

• Object Cache - Improving Response Times

• NetType - Selecting a Net Type

• Template - Location of Temporary Working Files

• DB Test - Testing the Database

• TestTarget

• DB Read-Only

 

Only in Tools/Options:

• Status Bar

• Close Forms on Esc

• Marquee Full Selection

• Quick Find

So, likely only default ZUP remains... (or mod in CU1, if it`s at all possible to set languahge from code - don`t know, I'm not a programmer)

 

Modris Ivans
MCP-Dynamics NAV Application

Please specify in your posts
1.product and DB version;
2.locale, or use International Forums

"Verify Solution" that helped you solve your problem

Male
244 Posts
5,247 Points
Joined: 2007-4-15
Last Online:
2014-2-20 2:55
Location: New Zealand
DynamicsNAVMVP
Moderator
Gaspode replied on 2008-12-18 4:05 | Locked

Hi Erik,

I know it's not going to help you on NAV 5.0 SP1, but in NAV 2009, there is a User Personalization table that contains a Language ID field (as well as the Profile ID, and Company).

How's that for a reason to upgrade? Big Smile

Cheers,

Dave.

Dave's Blog

Male
7,691 Posts
436,003 Points
Joined: 1995-10-1
Last Online:
2014-10-31 23:58
Location: Middelfart, Denmark
DynamicsNAVMVP
SystemAdministrator
Erik P. Ernst replied on 2008-12-18 9:06 | Locked

Well are you setting this at the same time as you define the users permissions, so that it's available when he first logs in (before actually opening the database)?

I have worked a little more with the problem myself. And what I have come to is that it's the Danish version which has been installed. The client folder (not the ENU or DAN folders) hold the exact same files as the W1 installation. With one exception. The FIN.STX. Besides the version codes, then there is a country code defined. In the Danish version it says DK. Does anyone know if changing this, or simply replacing the FIN.STX file with the standard W1 STX file would also affect the Lannguage setting?

Best regards,
Erik P. Ernst
Webmaster 

DUG’s Admin's Blog

Don't forget to "Verify Solution" the post(s) that solved your problem. This credits the experts who helped, earns you points and marks your thread as Resolved so we all know you have been helped.

Male
2,117 Posts
45,466 Points
Joined: 2005-12-6
Last Online:
2014-10-31 22:37
Location: Rælingen (Akershus), Norway
Moderator
Modris Ivans replied on 2008-12-18 11:30 | Locked

fin.stx is CRC-checked (or checsum, or hash?) on program start - it can't be edited in Notepad, that results in message "Invalid .stx.."

and, as far as I remeber, .stx language code must be equal to your license (there is country version encoded, too) - at least I had problems some years ago, when our LV .stx was "buggy" and MS corrected it only after 2-3 months... BTW there still exists a way to edit a .stx, but I don't know who has access to corresponding tool - maybe localization partners.

Modris Ivans
MCP-Dynamics NAV Application

Please specify in your posts
1.product and DB version;
2.locale, or use International Forums

"Verify Solution" that helped you solve your problem

Male
7,691 Posts
436,003 Points
Joined: 1995-10-1
Last Online:
2014-10-31 23:58
Location: Middelfart, Denmark
DynamicsNAVMVP
SystemAdministrator
Erik P. Ernst replied on 2008-12-18 11:47 | Locked

Yes I know the fin.stx file is locked somehow. But when you know someone who can lock it for you, then it's not the big problem.

In my case it would proberly be easier just to use the W1 FIN.STX - but I only want to do that if the Country code in this field really has anything do with the default language setup of the client.

Best regards,
Erik P. Ernst
Webmaster 

DUG’s Admin's Blog

Don't forget to "Verify Solution" the post(s) that solved your problem. This credits the experts who helped, earns you points and marks your thread as Resolved so we all know you have been helped.

|
Page 1 of 1 (10 items) | Bookmark and Share