Added field name not visible in report

Hi Eveyone,

I added paymReference field to the tmpLedgerTransExtract table in order to have it on LedgerTransStatement report by the solution provided here:

http://dynamicsuser.net/forums/p/71808/383264.aspx#383264

But despite adding prompt field in Auto and Generated Design of the report, I have the paymReference values being shown on the report but the column name (i.e. Payment Reference) is missing. I have tried everything that I can think of.

I appreciate the experienced members of any help that they can provide.

Thanks.

  • Normal 0 false false false EN-US X-NONE X-NONE

    Infact I would be more precise. Adding on one PageHeader the name does appear but not at the right place. It is one level above all the other column names.

     

  • In reply to Sajid Hanif:

    Normal 0 false false false EN-US X-NONE X-NONE

    As I am discovering by doing different experiments, it seems as my added prompt control is missing the ModelFieldName property. It is this property which dictates probably the left alignment of a control. But what I don’t understand is that what is the source of this property. Where exactly it comes from ???

  • In reply to Sajid Hanif:

    Normal 0 false false false EN-US X-NONE X-NONE

    I found answer to my question by experimenting. In fact the prompt control uses the name of its corresponding field from the body of the report as the ModelFieldName and that is how it aligns itself.

    Good to know that.

Related